Tag Archives: Critical Apple Updates

Security Update: FORCEDENTRY – Update your Apple Devices

Security Update

A critical security vulnerability called FORCEDENTRY on IOS and MacOS devices means you should update immediately. Earlier this week apple released a critical software patch to fix an exploit that allows attackers to directly infect iPhones and other Apple devices.  No user interaction is needed, which makes this attack particularly dangerous. The exploit was originally […]